Shinden's Lair.


Home | About me | moje CV / my resume | RSS 2.0

Mon, 28 May 2007

Moje otwarte boje

Na fali ostatnich walk z pewnym routerem z ipsec na OpenBSD, postanowiłem zainstalować na laptopie ten system i przyjrzeć się mu z bliska. Miałem wcześniej ściągnięte ISO OpenBSD4.1, więc jak postanowiłem, tak zrobiłem. Sama instalacja, jak to z BSD, poszła szybko. Potem dociągnąłem programy z paczek binarnych. Wszystko poszło łatwo i przyjemnie. W ciągu pół godziny miałem środowisko, do którego byłem przyzwyczajony z NetBSD. Następnie postanowiłem uaktualnić programy z portów. Nie obyło się bez problemów, ale poszło. Na fali uaktualnień dobiłem do 4.1-current, by wypróbować Xenocara - wersję X.org7.2 pod OpenBSD. Uaktualnienie poszło gładko, system wstał normalnie, musiałem tylko ręcznie uaktualnić katalog /etc/X11. I tu zaczęły się problemy m.in. z gtk+2. W związku z tym, ze cairo oraz expat zostały dodane do Xenocary, musiałem całkowicie zdeinstalować gtk+2 (i wszystko co z nim było związane oraz przekompilować je jeszcze raz. Pakiety binarne, które były kompilowane pod ten snapshot niezbyt działały. W końcu jakoś udało mi się doprowadzić do stanu normalnego, w którym wszystko działało. Ale w wyniku tych updatów w końcu nie przeprowadziłem tego, czego chciałem - nie potestowałem ipsecctl. Dlatego, że w niedzielę wieczorem zacząłem powrót do NetBSD. Nie to, że NBSD obsługuje ACPI, WPA (4_0BETA2 albo current) czy ma inne wersje programów (wolę jednak pkgsrc od portów z opena). Ale przy włączonym ACPI na 4.1-current OpenBSD nie potrafił się sam wyłączyć. Sam system chodził dość wolno, choć dało się pracować - większe bezpieczeństwo (jakkolwiek ono by nie było) ma swoją cenę. Stabilnie chodził plugin flasha (chociaż tylko pod Operą, więc niejako zostałem zmuszony do używania jej). Więc teraz mam nadal NetBSD w wersji 4.99.20 (current), z Firefoxem, flashem w nim, sylpheed-claws (moja paczka z claws-mail poszła z newfs :\). I na razie z tym zostanę.

posted at: 16:35 | Tags: Operating Systems | permalink


Made with Pyblosxom Viewable With Any Browser Valid XHTML 1.0 Strict